Posting to Pleroma inbox

Hi @naturzukunft. I unfortunately don’t have the solution, but would like to point you to Guide for new ActivityPub implementers, which is a wiki post for anyone to edit. Once you fix this issue, it might be helpful to add to this tutorial for the next person that comes after you, if you can spare a couple of minutes to update :blush:

I’m not sure, that object is a valid AS object as far as Pleroma 1.x is concerned, but Pleroma 2 has a different validation engine which may actually be too strict here. I would suggest filing a bug though, as this is a conformance issue.

Do you no a pleroma instance that is well maintained and the newest version is deployed? i don’t know how this is at

$ curl -sSL | jq .version
"2.7.2 (compatible; Pleroma 2.2.2)"

And with checking at, you can see that it’s the latest version.

What would more likely help you is to have the server logs, “Internal Server Error” often means “check/ask for server logs”.

Are there any examples out there, preferably with curl, from someone who has already played with pleroma ?

I managed to post activites to pleroma. When I query my outbox afterwards, I get a json. unfortunately, you can’t attach files here.

When I run this through my parser, I get:

com.github.jsonldjava.core.JsonLdError: recursive context inclusion:

Maybe this works:

Error occurs in Line 194

See also the following id’s in this document

  • #ter02
  • #ter03

I’m not able to post a bug report (yet), because i need a account.

Conclusion: Playing with activityPub is somehow annoying and anything but fun

^ [ActivityPub C2S] JsonLdError: recursive context inclusion (users outbox) (#2540) · Issues · Pleroma / pleroma · GitLab

Agree with @lanodan that this seem to be a bug in jsonld-java’s recursive context parsing—it maintains a global list of all remote contexts defined in the entire document, and errors whenever a remote context is referenced twice. It looks like this was fixed in this PR: Throw RECURSIVE_CONTEXT_INCLUSION only when cyclic dependency exists by umbreak · Pull Request #303 · jsonld-java/jsonld-java · GitHub, which doesn’t appear to be included in the version you linked. However, for parsing Pleroma’s output, this issue may also be relevant: JSON-LD 1.1 missing scoped context support · Issue #288 · jsonld-java/jsonld-java · GitHub

1 Like

Yesterday i had the same issue by reading a pleromas actor profile. i upgraded to the newest version of jsonld-java and it worked!

no i’m struggling with other “issues”. It seems to be a long way ;-(

And the C2S Issues are a little bit old: Issues · Pleroma / pleroma · GitLab

My next problem: [ActivityPub C2S] json+ld type vs. @type (#2638) · Issues · Pleroma / pleroma · GitLab

A ton of stuff in Pleroma is done directly with Merge Requests, issues are basically created when it’s not practical to create a (WIP) Merge Request and I don’t think we have good labeling.

It means that AP C2S · Search · GitLab is more accurate.