Some instance can't see my actor, can anybody help me debug that?


I’m working on an XMPP⬌ActivityPub Gateway (see Libervia progress note 2022-W45 - Libervia) but it seems that some people can’t see my actor data (see j.r: " seems like I can't search …" - - Mastodon).

My TLS certificate looks fine, I can do the requests manually and get expected responses, and I can see this account from my Mastodon account.

Can anybody help me debug this issue? If you are running your own instance and can’t see my actor, I would appreciate to know which software/version your are using, and which relevant logs you have.


what diagnosis have you done so far?

using such a webfinger script to debug:


# RFC 7033

curl -L "https://$(echo "${1}" | cut -d'@' -f2)/.well-known/webfinger?resource=acct:${1}"

I see no "rel": "" entry which may be mandatory.

I tried $ webfinger | jq .

Thanks for your quick answer.

I see no "rel": "" entry which may be mandatory.

Oh, is it? I haven’t found anything in RFC 7033 - WebFinger stating that it’s mandatory. Anyway I’ll try to add it, we’ll see.

The most suspicious thing that I see in my log is that many request to my actor are redirected to my HTML rendered page, which normally happens only when no accept: application/activity+json header is found in the request.

There was a bug in my Accept header check which is probably the source of the issue. I’ll wait for confirmation from the people who reported the initial issue, and will report it here.

1 Like

It’s confirmed working by the user. So for the record, the issue was due to a bug in my implementation which was redirecting ActivityPub queries to the HTML rendered page. Thanks for the help.

edit: I would like to mark the topic as “solved”, but it seems that it’s not possible with this forum configuration (or I’ve missed something).

1 Like