Webfinger issue


I’ve got a webfinger resolver(?) going in nodejs that works with the few mastadon servers I’ve tried, but doesn’t work with @fediverse@socialhub.activitypub.rocks

It works okay with a plain browser GET:


This successfully shows the webfinger subject/links etc. However, when I try to fetch() the same URL from my nodejs v21.4.0 (with ‘stable’ fetch!) app I get an ETIMEDOUT error:

[2023-12-20T09:14:40.762Z] Fetching: https://socialhub.activitypub.rocks/.well-known/webfinger?resource=acct:fediverse@socialhub.activitypub.rocks
[2023-12-20T09:14:41.070Z] TypeError: fetch failed
    at node:internal/deps/undici/undici:12442:11
    at process.processTicksAndRejections (node:internal/process/task_queues:95:5) {
  cause: AggregateError [ETIMEDOUT]: 
      at internalConnectMultiple (node:net:1114:18)
      at afterConnectMultiple (node:net:1667:5) {
    code: 'ETIMEDOUT',
    [errors]: [ [Error], [Error] ]

This happens about .3 of a second after the fetch which is a quick timeout for a web request!

I’ve tried the same thing from an online REPL and get a generic NetworkError. Maybe CORS related?

Any ideas? It’s not really a big deal as I’m mostly concentrating on mastodon interop right now, but I’m obviously missing something and discourse interop would be nice too.


tagging @angus as they are the one working on the Discourse integration

1 Like

Hey @marksibly thanks for the report. I’ll investigate this in a bit more depth later this week.

@marksibly There have been a few updates recently, and there’s another coming soon

I might ask you to test again once that PR is in and this site is updated to the latest version of the plugin.